Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Tag: android gradle

Excluir .jar de compilar en Android Studio con Gradle

Actualmente tengo algo como esto en el archivo build.gradle. dependencies { compile 'com.android.support:support-v4:13.0.+' compile ('com.xxx:xxx-commons:1.+') { } } Un problema surge ya que tanto jUnit como hamcrest-core están presentes en el repositorio com.xxx:xxx maven, creando un error como este: Gradle: Origin 1: /Users/yyy/.gradle/caches/artifacts-26/filestore/junit/junit/4.11/jar/4e031bb61df09069aeb2bffb4019e7a5034a4ee0/junit-4.11.jar Gradle: Origin 2: /Users/yyy/.gradle/caches/artifacts-26/filestore/org.hamcrest/hamcrest-core/1.3/jar/42a25dc3219429f0e5d060061f71acb49bf010a0/hamcrest-core-1.3.jar Gradle: Execution failed for task ':android:packageDebug'. > Duplicate […]

¿Qué es la versión de complemento de Android incluida en IntelliJ IDEA?

… y cómo averiguarlo (de una manera autorativa)? En Android Studio 0.8.11: cuando compruebo el mismo se muestra 10.0.8.11. Que corresponde a http://tools.android.com/recent y http://developer.android.com/sdk/installing/studio.html . En IDEA EAP 14: cuando vaya a Configuración> Plugins> Android Support el número de versión mostrado es 10.0 que no corresponde a una versión reciente de IDEA / Android […]

La sincronización de Gradle falló después de cambiar a 3.0 canary 5

Después de cambiar a Android Studio 3.0 canary 5 No puedo construir mi gradle después de una cierta búsqueda descubrí que el error se debe a la biblioteca de guayabas obsoleta, pero no estoy usando Guava en mi proyecto. Proyecto Gradle buildscript { ext.kotlin_version = '1.1.3' repositories { jcenter() maven { url 'https://maven.fabric.io/public' } } […]

Error con Android Gradle plugin 0.13 y android-apt 1.3

Acabo de actualizar mi androide gradle plugin de 0,12 a 0,13. Además he descargado gradle 2.1. Entonces, he intentado con el estudio de Android 0.8.9 en la versión beta, pero de acuerdo con http://tools.android.com/tech-docs/new-build-system/version-compatibility Tengo que utilizar al menos el android studio 0.8.11 (canary canal). Así que he actualizado mi estudio de Android, pero todavía […]

Android: El uso de SVG en res lleva al error: "El nombre del archivo debe finalizar con .xml o .png"

Acabo de actualizar Android Studio 1.2.1.1 y ahora gradle tiene problemas con svg en mi carpeta de recursos. Siempre estuve usando SVG sin ningún problema y espero que se "permitan" en el futuro. :app:mergeDebugResources :app:mergeDebugResources FAILED /home/petergriffin/folder1/another-app/MyAwesome-App/app/src/main/res/drawable-hdpi/logo.svg Error:Error: The file name must end with .xml or .png Error:Execution failed for task ':app:mergeDebugResources'. > /home/petergriffin/folder1/another-app/MyAwesome-App/app/src/main/res/drawable-hdpi/logo.svg: Error: […]

La generación de Gradle no pudo resolver la dependencia de la biblioteca aar (trnql sdk)

Cuando intento construir mi proyecto usando gradle, consigo el error siguiente: Failed to resolve: com.trnql:lib-release 1.0.0 Parece que no puede encontrar el archivo de archivo android (aar) que está en la carpeta libs. La sección de dependencias del archivo build.gradle tiene este aspecto: Y la estructura del proyecto se ve así: El archivo aar es […]

Google GCM Android bloquea (java.lang.NoClassDefFoundError: com.google.android.gms.R $ cadena)

Estoy desarrollando una aplicación utilizando el servicio Google GCM y parece que se está estrellando en todos los dispositivos pre-lollipop en el lanzamiento .. He seguido tutorial de google … y su trabajo en lollipop y malvavisco Aquí están mis dependencias a nivel de proyecto dependencies { classpath 'com.android.tools.build:gradle:1.5.0' classpath 'com.google.gms:google-services:1.5.0' } Tengo esto en […]

No se pudo resolver: com.google.android.gms: play-services-cast: 9.8.00

Estoy usando Android Studio y he clonado la aplicación de referencia de CastVideo v2 y la he configurado con la CastCompanionLibrary según sus instrucciones. Sin embargo, cuando intento sincronizar el proyecto gradle, dice: Failed to resolve: com.google.android.gms:play-services-cast:9.8.00 . Tengo la opción de Install Repository and sync project pero no hace nada. He intentado hacer Invalidate […]

Android Gradle – cargar la configuración de firma desde un archivo externo

En Gradle para Android parece ser común la práctica de definir su firma de configuración para la versión de construcción como este: android { signingConfigs { debug { storeFile file("debug.keystore") } myConfig { storeFile file("other.keystore") storePassword "android" keyAlias "androiddebugkey" keyPassword "android" } } buildTypes { foo { debuggable true jniDebugBuild true signingConfig signingConfigs.myConfig } } […]

Error de generación en Android Studio

Después de actualizar todas las bibliotecas de soporte de Google a las versiones más recientes, de v21 a v22.2.0 y Play Services a v7.5, mi proyecto ya no se genera correctamente. El log que obtengo es el siguiente: app:preDexDebug AGPBI: {"kind":"simple","text":"Picked up JAVA_TOOL_OPTIONS: -javaagent:/usr/share/java/jayatanaag.jar ","sources":[{}]} AGPBI: {"kind":"simple","text":"Picked up JAVA_TOOL_OPTIONS: -javaagent:/usr/share/java/jayatanaag.jar ","sources":[{}]} AGPBI: {"kind":"simple","text":"Picked up JAVA_TOOL_OPTIONS: […]

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.