Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Tag: Gradle

Android Studio Gradle Configuración con nombre 'default' no encontrado

Tengo problemas para compilar mi aplicación con Android Studio (0.1.5). La aplicación utiliza 2 bibliotecas que he incluido de la siguiente manera: Settings.gradle include ':myapp',':library',':android-ColorPickerPreference' Construir un gradiente buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.4' } } apply plugin: 'android' dependencies { compile files('libs/android-support-v4.jar') compile project(':library') compile project(':android-ColorPickerPreference') } android { compileSdkVersion […]

Android Studio de repente no puede resolver los símbolos

Android Studio 0.4.2 estaba funcionando bien y hoy la abrí y casi todo estaba en rojo y la autocompleción había dejado de funcionar. Miro las importaciones y AS parece estar diciéndome que no puede encontrar android.support.v4 de repente (me ofrece la opción de eliminar las importaciones no utilizadas). ( Android.support.v7 parece estar bien aunque). Cosas […]

¿Cómo uso las herramientas: overrideLibrary en un archivo build.gradle?

Estoy utilizando las bibliotecas de leanback, que requieren Android 17 o posterior. Sin embargo, mi aplicación es compatible con un minSDK de 16, por lo que obtener un error de compilación de gradle diciendo Error:Execution failed for task ':Tasks:processPhoneDebugManifest'. > Manifest merger failed : uses-sdk:minSdkVersion 16 cannot be smaller than version 17 declared in library […]

Aceptar automáticamente todas las licencias de SDK

Ya que gradle android plugins 2.2-alpha4 : Gradle intentará descargar paquetes de SDK que faltan de los cuales depende un proyecto Lo cual es sorprendentemente cool y se sabe que es un proyecto de JakeWharton . Sin embargo, para descargar la librería SDK necesita: aceptar los acuerdos de licencia o gradle le dice: No ha […]

Com.android.build.transform.api.TransformException

Estoy tratando de integrar google inicio de sesión, en mi aplicación, he añadido estas bibliotecas: compile 'com.google.android.gms:play-services-identity:8.1.0' compile 'com.google.android.gms:play-services-plus:8.1.0' También agregar esto al gradle de la construcción del proyecto: classpath 'com.google.gms:google-services:1.4.0-beta3' También añadir complemento a la aplicación de construcción gradle: apply plugin: 'com.google.gms.google-services' A continuación, agregar los permisos necesarios, pero cuando intento ejecutar mi aplicación, […]

Error: (1, 0) No se encontró el complemento con id 'com.android.application'

Este es mi primer intento en Android Studio. He instalado 0.8.0 y actualizado a 0.8.2. Tan pronto como se crea un proyecto, obtengo el mensaje de error: Error: (1, 0) No se encontró el complemento con id 'com.android.application' C: \ Usuarios \ Bob \ AndroidStudioProjects \ HelloAgain6 \ app \ build.gradle apply plugin: 'com.android.application' android […]

Usando Build Flavors – Estructurar las carpetas de origen y build.gradle correctamente

Tenga en cuenta: Respuesta editada después de la respuesta de Xavier Estoy tratando de usar diferentes sabores de construcción para un mismo proyecto de aplicación en Android Studio. Sin embargo, parezco tener un tiempo terrible configurándolo para trabajar apropiadamente. Pasos: Cree un nuevo proyecto de Android Studio, denominado 'Prueba'. Abra build.gradle * y agregue las […]

La creación y ejecución de aplicaciones a través de Gradle y Android Studio es más lenta que a través de Eclipse

Tengo un multiproyecto (~ 10 módulos) de que la construcción tarda unos 20-30 segundos cada vez. Cuando presiono Ejecutar en Android Studio, tengo que esperar cada vez para reconstruir la aplicación, que es extremadamente lento. ¿Es posible automatizar el proceso de construcción en Android Studio? ¿O tiene algún consejo sobre cómo hacer este proceso más […]

No se pudo encontrar com.google.android.gms: play-services: 3.1.59 3.2.25 4.0.30 4.1.32 4.2.40 4.2.42 4.3.23 4.4.52 5.0.77 5.0.89 5.2.08 6.1. 11 6.1.71 6.5.87

Haciendo referencia a los servicios de juego a través de gradle dejó de funcionar para mí – se redujo a hervir – incluso la muestra que utiliza como referencia en el primer lugar dejó de funcionar: https://plus.google.com/+AndroidDevelopers/posts/4Yhpn6p9icf FAILURE: Build failed with an exception. * What went wrong: A problem occurred configuring project ':auth'. > Failed […]

Appcompat-v7: 21.0.0 ': No se encontró ningún recurso que coincida con el nombre dado: attr' android: actionModeShareDrawable '

Al intentar utilizar la última biblioteca de soporte appcompat-v7 en mi proyecto, obtengo el siguiente error: /Users/greg/dev/mobile/android_project/app/build/intermediates/exploded-aar/com.android.support/appcompat-v7/21.0.0/res/values-v11/values.xml Error:(36, 21) No resource found that matches the given name: attr 'android:actionModeShareDrawable'. Error:(36, 21) No resource found that matches the given name: attr 'android:actionModeShareDrawable'. Error:(36, 21) No resource found that matches the given name: attr 'android:actionModeShareDrawable'. Error:(36, 21) […]

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.