Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Tag: Gradle

Cómo suprimir Android Lint advertencia en Gradle script

Tengo la siguiente advertencia molesta en mi informe de Lint de Android: Gradle Dependency: Obsolete Gradle Dependency A newer version of com.android.support:appcompat-v7 than 20.+ is available: 21.0.0-rc1 El problema es que no puedo usar 21.0.0-rc1 porque no funciona con mi proyecto. ¿Cómo puedo suprimir la advertencia?

¿Cómo puedo especificar por sabor buildType sourceSets?

Tengo 2 sabores de una aplicación que cada uno tiene su propia clave de google maps (v1) para la depuración y la liberación (lo que significa total de 4 claves). Así que me gustaría saber si puedo especificar sourceSets basado en el buildType y productFlavor. Esencialmente, me pregunto cómo puedo lograr algo como esto: src […]

Android Studio 0.5.2 Gradle Refresh Project falló

ACTUALIZADO CON MI REGISTRO DE EVENTOS ÚLTIMO EDIT Después de probar todas las posibles soluciones que podría encontrar he llegado a una nueva instalación de Windows. Haciendo esto me di cuenta de que esto era indeeed un problema de firewall , mi antivirus estaba bloqueando el studio64.exe process. Tengo recientemente instalado Android Studio 0.4.2 luego […]

IntelliJ y Android Dependencias de Gradle – no puede encontrar el módulo

Tengo siguiente estructura del directorio: D:\PROJECT +—javaGradleProject1 +—javaGradleProject2 +—javaGradleProject3 \—AndroidProject | build.gradle | settings.gradle \—AndroidModule build.gradle El módulo de Android depende de todos los proyectos de java gradle que están en el mismo nivel en el directorio raíz que en AndroidProject. En AndroidProject / settings.gradle tengo: include ':AndroidModule' include 'javaGradleProject1' project(':javaGradleProject1').projectDir = new File(rootDir, '../javaGradleProject1') […]

¿Cómo puedo determinar la versión de los servicios de Google Play?

Estoy migrando de Eclipse a Android Studio. Tengo un proyecto que importé en Android Studio que utiliza Google Play Services, por lo que estoy siguiendo la documentación que encontré aquí: http://developer.android.com/google/play-services/setup.html Esta documentación dice que yo Necesito editar mi archivo build.gradle . Ellos dan el ejemplo: apply plugin: 'com.android.application' … dependencies { compile 'com.android.support:appcompat-v7:21.0.3' compile […]

Atributos de vista personalizada de Android que no funcionan después de cambiar a gradle

Así que recientemente migré a gradle ahora mis atributos de vista personalizada devuelven null Mi proyecto se ve así –custom_icon_view // biblioteca que contiene la vista personalizada con atributos personalizados – mi aplicación // esta es la aplicación principal que realmente utiliza la vista personalizada En mi diseño tengo el espacio de nombres definido como […]

¿Cómo comprobar el tamaño de las dependencias en una aplicación para Android?

Estoy trabajando en una aplicación para Android que ya tiene muchas dependencias en ella. Quiero eliminar algunos de los más grandes. ¿Cómo comprobar su tamaño en la aplicación?

Error al crear una aplicación Codename One grande durante la fase Dex

Tengo un error en el servidor de compilación al enviar una compilación de Android durante la fase dex. Googling un poco me enteré de que hay un límite de 64K funciones (incluyendo todas las librerías, el más pesado es google play servicios), o puede utilizar el mecanismo de múltiples dex. ¿Cómo activo esto para Codename […]

Cómo incluir la dependencia de JAR en una biblioteca AAR

Resumen: Tengo un archivo AAR que depende de un archivo JAR, cuando construyo el proyecto AAR, no contiene el código JAR. Detalles: Tengo un proyecto de biblioteca Java SDK que contiene el código que utilizamos para proyectos web java y tal, esta biblioteca se crea con Gradle y reside en un servidor interno nexo (como […]

Cómo establecer severityOverrides en lintOptions?

Tengo un proyecto de Android que define buildscript { repositories { jcenter() } dependencies { // Android plugin for gradle // http://google.github.io/android-gradle-dsl classpath 'com.android.tools.build:gradle:1.5.0' // … En mi aplicación quiero establecer android { // … lintOptions { // http://google.github.io/android-gradle-dsl/1.5/com.android.build.gradle.internal.dsl.LintOptions.html#com.android.build.gradle.internal.dsl.LintOptions:severityOverrides severityOverrides { ["MissingTranslation": "warning"] } // … Pero consigo el error Error: (34, 0) Método Gradle […]

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.