Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Tag: Gradle

No se puede ejecutar ndk-build en el estudio de Android desde gradle on osx yosemite

Estoy tratando de ejecutar ndk-build desde mi build.gradle en un proyecto Android Studio 1.0 en MAC OSX Yosemite. task ndkBuild(type: Exec) { commandLine 'ndk-build', '-C', file('src/main').absolutePath } He especificado el ndk-dir en el archivo local.properties pero estoy recibiendo este error A problem occurred starting process 'command 'ndk-build' Si ejecuto el script gradle desde la línea […]

Desbloqueo de APK de Android con java.lang.AssertionError: imposible en java.lang.Enum

Acabo de construir un APK usando Gradle para la liberación (ProGuard 4.9 y firmado). Cuando lanzo la aplicación se bloquea en este error: E/AndroidRuntime( 8662): java.lang.AssertionError: impossible E/AndroidRuntime( 8662): at java.lang.Enum$1.create(Enum.java:44) E/AndroidRuntime( 8662): at java.lang.Enum$1.create(Enum.java:35) E/AndroidRuntime( 8662): at libcore.util.BasicLruCache.get(BasicLruCache.java:54) E/AndroidRuntime( 8662): at java.lang.Enum.getSharedConstants(Enum.java:210) E/AndroidRuntime( 8662): at java.lang.Enum.valueOf(Enum.java:190) E/AndroidRuntime( 8662): at kr.infli.sZ(Inflikr.java:390) E/AndroidRuntime( 8662): at kr.infli.a.ev(Inflikr.java:409) […]

Gradle no puede encontrar la dependencia de google play

Intento reparar la dependencia a los servicios del juego de google en mi proyecto del androide. Ya funcionó pero ahora está roto. Creo que esto sucedió entre el Android Studio beta y la versión de lanzamiento. Esta es la dependencia en el archivo build.gradle: dependencies { compile 'com.google.android.gms:play-services:6.5.87' } Android Studio fue capaz de autocompletar […]

Cómo obtener 'Error: No se puede obtener la propiedad': lib 'on null object` en un nuevo proyecto de Android Studio

He creado un nuevo proyecto con Android Studio y agregado un nuevo proyecto de lib dentro, pero ahora estoy recibiendo esto: Error:Cannot get property ':lib' on null object .

Gradle genera para cada carpeta de recursos

¿Es posible configurar Gradle para construir algunos archivos androide de apk donde cada uno usaría sólo una carpeta de tipo de recurso? Quiero decir: Build-hdpi.apk Build-mdpi.apk Build-xhdpi.apk Sé que podría simplemente eliminar ciertas carpetas antes de la construcción, pero sería bueno si yo podría hacerlo "automagically". ¿Sería posible usar gradle "sabores"?

Establecer valor constante con gradle

Acabo de mover al androide gradle construir sistema y no está claro para mí cómo establecer valores constantes. Por ejemplo, tengo API.java que contiene BASE_URL = "http://debug.server.com" Pero cuando gradle construye la liberación necesito BASE_URL ser "http://release.server.com" ¿Cómo reemplazar este valor en el tiempo de construcción?

Error de OpenCV Library con AndroidStudio

Tengo problemas con el proyecto actual de Android en el que estoy trabajando, tiene OpenCV Library importado como módulo y configurado como dependencia. Después de actualizar Android Studio de 0.8.14 a 1.0, y tratando de sincronizar Gradle estoy recibiendo error siguiente: Error: Los proyectos de biblioteca no pueden establecer applicationId. ApplicationId se establece en 'org.opencv' […]

No se puede agregar ViewPagerIndicator a la aplicación con Gradle

Estoy tratando de agregar Jack Whartons ViewPagerIndicator biblioteca https://github.com/JakeWharton/ViewPagerIndicator a mi aplicación como quiero usar el indicador de círculo para el viewpager que tengo. Sin embargo, tengo problemas para añadirlo a mi aplicación. He seguido este tutorial – Uso de la biblioteca ViewPagerIndicator con Android Studio y Gradle Sin embargo, estoy recibiendo este error Error:Artifact […]

Android: el prefijo "xmlns" no puede estar enlazado a ningún espacio de nombres explícitamente; Tampoco puede el espacio de nombres para "xmlns" estar vinculado a cualquier prefijo explícitamente

¿Alguien está recibiendo este problema de espacio de nombres "xmlns" (ver más abajo)? Ya no puedo construir mi proyecto de trabajo. Al principio pensé que era mi rama git, así que cambié al origen desarrollar y dominar ramas – tema persiste. Limpié y reconstruí mi proyecto – el problema persiste. Limpié y sincronizado mis archivos […]

Android: No se pudo encontrar com.android.support:support-v4:23.2.1

Añado esta biblioteca en mi archivo gradle: compile 'com.appeaser.sublimepickerlibrary:sublimepickerlibrary:2.0.0' Ya tengo estas dependencias: dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile "com.android.support:design:23.+" compile 'com.android.support:support-v4:23.+' compile 'com.android.support:support-v13:23.+' compile 'com.android.support:appcompat-v7:23.+' compile 'com.android.support:cardview-v7:23.+' compile 'com.android.support:recyclerview-v7:23.+' Desde que he añadido la biblioteca SublimePicker, agrego este error: Error: No se pudo encontrar com.android.support:support-v4:23.2.1. Requerido por: Android: aplicación: no especificado ¿Podrías […]

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.