Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Error "Se requiere la versión 1.10 de Gradle. La versión actual es 1.12. "Al ejecutar" gradle wrapper "?

Estoy tratando de ejecutar gradle wrapper para un proyecto de Android, y este error se plantea:

Se ha producido un error al evaluar el proyecto raíz 'myapp'.

  • \ Build \ intermedios \ res \ recursos-anzhi-debug-stripped.ap_ 'especificado para la propiedad' resourceFile 'no existe
  • Utilizar un manifestPlaceholder diferente para cada variante de generación
  • Cómo importar Android Studio Project de Git
  • Android - La ejecución falló para la tarea ': app: compileDebugJavaWithJavac'
  • Android Studio: No se pudo encontrar com.android.tools.build:gradle:2.0.0-alpha2
  • Crashlytics - diferentes nombres de paquetes para diferentes sabores gradle
  • > Se requiere la versión Gradle 1.10. La versión actual es 1.12. Si utiliza el gradle wrapper, intente editar la distribuciónUrl en /Users/dude/myapp/gradle/wrapper/gradle-wrapper.properties para gradle-1.10-all.zip

    Mi tarea de wrapper en build.gradle ve así:

     task wrapper(type: Wrapper) { gradleVersion = "1.12" } 

    Recientemente he actualizado a Gradle v1.12 a través de Homebrew. ¿No es apoyado o algo? Si es así, ¿dónde puedo comprobar este tipo de cosas?

  • Soporte de Android para AVRCP
  • Recursos $ NotFoundException al usar Robolectric con Gradle
  • ¿Cómo puedo ejecutar código en un hilo de fondo en Android?
  • ¿Cómo puedo ocultar / mostrar un elemento cuando se presiona un botón?
  • No auto lanzar aplicación cuando ejecuto a través de estudio de android
  • Android - La ejecución falló para la tarea ': app: compileDebugJavaWithJavac'
  • 3 Solutions collect form web for “Error "Se requiere la versión 1.10 de Gradle. La versión actual es 1.12. "Al ejecutar" gradle wrapper "?”

    Una versión particular del complemento de Gradle Android requiere una versión particular de Gradle (al menos por ahora), y parece que su versión del complemento de Gradle Android requiere Gradle 1.10. Puede encontrar más información al respecto en la documentación del complemento Android de Gradle.

    PS: La tarea wrapper anterior crea los archivos necesarios para ejecutar Gradle con el script gradlew (generado), que es la forma preferida de ejecutar Gradle (no hay instalación manual, cada build puede especificar en su gradle-wrapper.properties la versión de Gradle que necesita ).

    La versión de Android gradle plugin debe ser compatible con la versión de Gradle. Compruebe la tabla de asignación de compatibilidad de versiones aquí: http://tools.android.com/tech-docs/new-build-system/version-compatibility

    Introduzca aquí la descripción de la imagen

    Yo tuve el mismo problema. Resultó que el viejo Android Studio creó gradle relacionados con los archivos de un nivel por encima de mi carpeta de aplicaciones. En mi caso, el camino estaba en ~ / git /, y mi proyecto estaba en ~ / git / myproject. Utilicé Android Studio RC2 ahora, y no importa cómo cambié la configuración dentro del proyecto, gradle todavía quería usar la vieja versión 1.10. Por lo tanto, volví a comprobar el proyecto una nueva ruta, y actualizado la versión de gradle referencia dentro del proyecto, a continuación, compilado.

    FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.