Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Mensaje de error: este SDK de Android requiere Android Developer Toolkit versión 22.6.1 o superior

Recientemente he encontrado el siguiente error:

Captura de pantalla del diálogo

  • ADT obtener BufferOverflowException en DDMS
  • No se pudo encontrar adb.exe - después de actualizar a Android SDK 2.3
  • Este SDK de Android requiere Android Developer Toolkit versión 14.0.0 o superior. ... Actualice ADT a la última versión
  • Instalar el complemento ADT en Eclipse
  • ¿Cómo puedo solucionar esta versión de la biblioteca de renderizado es más reciente que su versión de ADT plug-in en eclipse
  • Android ADT versión 22, archivos R.java no generados
  • Lo más extraño es que acabo de actualizar algunos paquetes de sdk a través de eclipse de trabajo. No hubo información o advertencia de que después de esta actualización se producirá un bloqueo del anuncio actual. He comprobado las últimas actualizaciones y no puedo encontrar el nuevo anuncio incluso en la página de google. Incluso el nuevo adb contiene adt viejo.

    Desde http://developer.android.com/tools/sdk/tools-notes.html :

    Dependencias: Android SDK Platform-tools revisión 18 o posterior. Si está desarrollando en Eclipse con ADT, tenga en cuenta que esta versión de SDK Tools está diseñada para su uso con ADT 22.6.1 y versiones posteriores. Si aún no lo ha hecho, actualice su ADT Plugin a 22.6.1.

    La única solución es descargar nuevo eclipse independiente y complemento externo para él? ¿Tiene el estudio de Android los mismos problemas?

    Entorno: linux x64.

  • ¿Cómo eliminar un recurso de cadena no utilizado para todas las configuraciones de Android Studio?
  • Servicio remoto vs. Servicio local
  • Android: Nivel de API VS. versión de Android
  • Cargador de archivos Android OpenGL .OBJ
  • Ofuscación: ocultar valores codificados en java
  • Cómo evitar que HttpClient 4 siga la siguiente redirección
  • 5 Solutions collect form web for “Mensaje de error: este SDK de Android requiere Android Developer Toolkit versión 22.6.1 o superior”

    Hoy, yo y uno de mis amigos enfrentamos el mismo problema, así que he intentado muchas cosas como reiniciar eclipse , revisar actualizaciones , etc., pero ninguna funcionaba para mí.

    Entonces encontré una solución de aquí y está funcionando como un encanto para mí y también para mi amigo.

    Siga los pasos aquí:

    • Inicie Eclipse y, a continuación, seleccione Ayuda> Instalar nuevo software.
    • Haga clic en Agregar, en la esquina superior derecha.
    • En el diálogo Añadir Repositorio que aparece, ingrese "ADT Plugin" para el Nombre y la siguiente URL para la Ubicación:

      https://dl-ssl.google.com/android/eclipse/

    • Haga clic en Aceptar.

    Si tiene problemas para adquirir el complemento, intente utilizar "http" en la URL de ubicación, en lugar de "https" (se prefiere https por razones de seguridad).

    • En el cuadro de diálogo Software disponible, seleccione la casilla de verificación junto a Herramientas de desarrollo y haga clic en Siguiente.
    • En la siguiente ventana, verá una lista de las herramientas que se van a descargar. Haga clic en Siguiente. Lea y acepte los acuerdos de licencia y, a continuación, haga clic en Finalizar.
    • Si recibe una advertencia de seguridad que indica que no se puede establecer la autenticidad o validez del software, haga clic en Aceptar.
    • Cuando finalice la instalación, reinicie Eclipse.

    Me informó de este error ayer. La solución es usar la opción Ayuda -> Instalar nuevo software con el protocolo httpS: // (es importante). No hay descargas especiales o re-instalaciones es necesario, sólo tienes que elegir el sitio de actualización correcta.

    El problema es que el sitio de actualización predeterminado en Android ADT es

    http://dl-ssl.google.com/android/eclipse/

    Pero este sitio no se actualiza correctamente

    Y la solución es añadir un nuevo sitio de instalación con el protocolo https

    https://dl-ssl.google.com/android/eclipse/

    Haga clic en Ayuda-> Instalar nuevo software-> Agregar

    Y utilizar este sitio para actualizar ADT

    Problema: https://code.google.com/p/android/issues/detail?id=67325

    Para resolver este problema, aquí he cubierto los pasos, seguramente le ayudará.

    Siga estos pasos:

    1. Ayuda | Instalar nuevo software

    2. Seleccione el sitio de actualización de ADT (hay dos, uno con http: // y otro con https: // Si uno no funciona, pruebe el otro.

    3. Seleccione la sección de herramientas para desarrolladores y pulse Siguiente.

    4. Debería ver un diálogo que dice "este software ya está instalado, se realizará una actualización en su lugar". Al hacer clic en ok, 22.6.1 se instalará.

    Actualización 27/03/2014

    Lanzaron 22.6.2 y solucionaron este problema para actualizar su ADT a la nueva versión.

    Puede ver este hilo: No se puede actualizar desde ADT 22.3.0. A 22.6.1

    Puede ir a Window-> Android SDK Manager y comprobar tha qué versión tiene. En mi caso, muestra que ya tengo el kit de herramientas 22.6.1 instalado, pero aún así obtener el error . Ya lo tenga o no, puede hacer lo siguiente para arreglarlo.

    • Ir a Ayuda-> Instalar nuevo software … En el cuadro de diálogo que se muestra a continuación, haga clic en el botón "Agregar" en la parte superior derecha.
    • Pegue " https://dl-ssl.google.com/android/eclipse/ " en Ubicación. Usted puede nombrar cualquier cosa.
    • Haga clic en Aceptar y siga el cuadro de diálogo haciendo clic en Siguiente.
    • Si se le solicita un mensaje de sasying ya lo tiene, sólo de acuerdo para que se actualiza (o instalado si no estaba allí).

    Esto debería resolver el problema. Fuente: http://codewriterstips.blogspot.nl

    Si su sdk androide es viejo. Usted debe descargar nuevo android sdk en developer.android.com y, copiar pasado algunos nececary carpeta en él.

    FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.