Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Una versión más nueva de com.android.support:appcompat-v7 que 23.2.1 está disponible: 24.0.0-alpha1

Aparece el siguiente error

Una versión más reciente de com.android.support:appcompat-v4 que 23.2.1 está disponible: 24.0.0-alpha1 y una versión más reciente de com.android.support:appcompat-v7 que 23.2.1 está disponible: 24.0.0- Alpha1

  • Pruebas de Android con Appium y Gradle
  • ¿Qué solución basada en plataformas móviles basada en Ruby utilizar?
  • Get String de EditText
  • Obtención de fuentes web para trabajar con phonegap y Android - ¿cómo?
  • Cómo simular un clic de botón con el código?
  • ANDROID / WEBVIEW- Uncaught TypeError: Object no tiene ningún método 'changeActivity' en el archivo:
  • Mi archivo build.gradle:

    apply plugin: 'com.android.application' android { compileSdkVersion 23 buildToolsVersion "23.0.2" defaultConfig { applicationId "com.zkc.i2ctools" minSdkVersion 8 targetSdkVersion 23 } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt' } } } dependencies { compile 'com.android.support:support-v4:23.2.1' compile 'com.android.support:appcompat-v7:23.2.1' compile files('libs/core-3.1.0.jar') } 

    Gradle construir con error. ¿Qué está mal?

  • Evento de inicio y fin de la aplicación para Android
  • ¿Cómo obtener el número de días entre dos instancia de calendario?
  • Los servicios de Google Play están desactualizados. Requiere 3025100 pero encontrado 2012110
  • ¿Se requiere setContentIntent (PendingIntent) en NotificationCompat.Builder?
  • ¿Cómo puedo hacer coincidir una revisión de Servicios de Google Play con una versión de instalación?
  • Obtenga el tiempo de caducidad de la API de suscripción de Android de Google para un token de suscripción.
  • 3 Solutions collect form web for “Una versión más nueva de com.android.support:appcompat-v7 que 23.2.1 está disponible: 24.0.0-alpha1”

    En realidad, hay un error, "Lint no debería sugerir la versión alpha de la dependencia de la biblioteca de soporte" https://code.google.com/p/android/issues/detail?id=203270

    Actualización (21-Marzo-2016)

    El error se ha combinado con esta https://code.google.com/p/android/issues/detail?id=203321 y se ha corregido para la versión 2.1 Future, el 11 de marzo

    Creo que puede estar confundiendo ese elemento de registro de nivel de información con un elemento de registro de nivel de error. Registros como este pasarán a través de su aplicación. Sin embargo esto no significa que algo en su aplicación está roto.

    No creo que debas actualizar a las versiones más recientes de appcompat hasta que estén fuera de alfa a menos que contengan características críticas / correcciones de errores que necesites.

    Si no puede construir, esa es otra historia en conjunto.

    Tuve el mismo problema esta mañana y mi compilación falló. A continuación, agregó lo que se sugiere en la generación de Gradle salida a la build.gradle correspondiente:

     lintOptions { abortOnError false } 

    Después de eso, todavía tengo el error para el archivo build.gradle correspondiente, pero al final la compilación tuvo éxito.

    Sin embargo, también me parece extraño que un lanzamiento alfa de algo sea empujado así por Lint …

    FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.